Back to overview
Degraded
Emails delivery is unavailable
Oct 29, 2025 at 5:42am UTC
Affected services
Secretary Portal
Member Portal
CiviCRM
Resolved
Oct 29, 2025 at 6:36am UTC
We've resolved this issue.
Affected services
Created
Oct 29, 2025 at 5:42am UTC
Email delivery is currently unavailable, affecting bulk email sends and sign in links. We're working on getting this fixed as soon as possible.
Affected services