Back to overview
Degraded
Errors accessing contacts
Mar 27, 2026 at 1:31am UTC
Affected services
Secretary Portal
CiviCRM
Resolved
Mar 27, 2026 at 2:10am UTC
We've resolved this issue.
Affected services
Created
Mar 27, 2026 at 1:31am UTC
Listing and viewing contacts is currently producing errors. We're working on getting this fixed.
Affected services